some text Contar valores em células filtradas – Excel

Quando precisamos  contar quantas vezes um número ocorre em um intervalo de linhas no Microsoft Excel usamos a formula “cont.se” e resolvemos facilmente o problema, mas quando aplicamos um filtro neste mesmo intervalo obviamente o “cont.se” vai continuar contando as células neste intervalo mesmo que elas estejam ocultas (filtradas) e em certos casos não queremos que isto ocorra. Usando a fórmula abaixo podemos resolver esta questão:

Neste exemplo queremos contar quantas vezes aparece o número 5 no intervalo A1:A20

=SOMARPRODUTO(SUBTOTAL(102;DESLOC(A1:A20;LIN(A1:A20)-LIN(A1);;1));–(A1:A20=5))

Podemos também utilizar a mesma fórmula para contar quantos números maiores  que 5 aparecem no intervalo.

=SOMARPRODUTO(SUBTOTAL(102;DESLOC(A1:A20;LIN(A1:A20)-LIN(A1);;1));–(A1:A20>5))

Ou menores que 5

=SOMARPRODUTO(SUBTOTAL(102;DESLOC(A1:A20;LIN(A1:A20)-LIN(A1);;1));–(A1:A20<5))

Usando esta fórmula quando aplicarmos algum filtro o excel vai desconsiderar as células ocultas (filtradas) e contar apenas as visíveis.

Sem filtro
Com filtro

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

Esse site utiliza o Akismet para reduzir spam. Aprenda como seus dados de comentários são processados.